$re = '/<(\/?)b\b((?:[^>"\']|"[^"]*"|\'[^\']*\')*)>/m';
$str = 'asd <b> asd </b> sdsadfs
asdas <b class="xx" title="asdasd"> sdsdfasd </b>
';
$subst = "<\1strong\2>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;