using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(\/?)b\b((?:[^>""']|""[^""]*""|'[^']*')*)>";
string substitution = @"<\1strong\2>";
string input = @"asd <b> asd </b> sdsadfs
asdas <b class=""xx"" title=""asdasd""> sdsdfasd </b>
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}