re = /<(\/?)b\b((?:[^>"']|"[^"]*"|'[^']*')*)>/m
str = 'asd <b> asd </b> sdsadfs
asdas <b class="xx" title="asdasd"> sdsdfasd </b>
'
subst = '<\\1strong\\2>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result