use strict;
my $str = 'asd <b> asd </b> sdsadfs
asdas <b class="xx" title="asdasd"> sdsdfasd </b>
';
my $regex = qr/<(\/?)b\b((?:[^>"']|"[^"]*"|'[^']*')*)>/mp;
my $subst = '<\\1strong\\2>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";