// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<(\/?)b\b((?:[^>"']|"[^"]*"|'[^']*')*)>"#).unwrap();
let string = "asd <b> asd </b> sdsadfs
asdas <b class=\"xx\" title=\"asdasd\"> sdsdfasd </b>
";
let substitution = "<\\1strong\\2>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}