import Foundation
let pattern = #"<(\/?)b\b((?:[^>"']|"[^"]*"|'[^']*')*)>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
asd <b> asd </b> sdsadfs
asdas <b class="xx" title="asdasd"> sdsdfasd </b>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<\1strong\2>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)