# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:[^:\n]+:\/\/)?[^\/\n]+(?:(?:\/[^\/\n]+)*?\/[^\/.\n]+)?$/\g<0>\//gm;t' <<< "www.mysite.com
http://www.example.com
www.mysite.com/page
http://www.mysite.com/doc1/doc2/page
http://www.mysite.com/page/
http://www.mysite.com/dir1/dir2/file.php
http://www.mysite.com/file.jpg
www.mysite.com/file.html
www.mysite.com/file.doc"