using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^:\n]+://)?[^/\n]+(?:(?:/[^/\n]+)*?/[^/.\n]+)?$";
string substitution = @"\g<0>/";
string input = @"www.mysite.com
http://www.example.com
www.mysite.com/page
http://www.mysite.com/doc1/doc2/page
http://www.mysite.com/page/
http://www.mysite.com/dir1/dir2/file.php
http://www.mysite.com/file.jpg
www.mysite.com/file.html
www.mysite.com/file.doc";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}