# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[^:\n]+://)?[^/\n]+(?:(?:/[^/\n]+)*?/[^/.\n]+)?$"
test_str = ("www.mysite.com\n"
"http://www.example.com\n"
"www.mysite.com/page\n"
"http://www.mysite.com/doc1/doc2/page\n"
"http://www.mysite.com/page/\n"
"http://www.mysite.com/dir1/dir2/file.php\n"
"http://www.mysite.com/file.jpg\n"
"www.mysite.com/file.html\n"
"www.mysite.com/file.doc")
subst = "\\g<0>/"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.