#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:[^:\n]+://)?[^/\n]+(?:(?:/[^/\n]+)*?/[^/.\n]+)?$"
Local $sString = "www.mysite.com" & @CRLF & _
"http://www.example.com" & @CRLF & _
"www.mysite.com/page" & @CRLF & _
"http://www.mysite.com/doc1/doc2/page" & @CRLF & _
"http://www.mysite.com/page/" & @CRLF & _
"http://www.mysite.com/dir1/dir2/file.php" & @CRLF & _
"http://www.mysite.com/file.jpg" & @CRLF & _
"www.mysite.com/file.html" & @CRLF & _
"www.mysite.com/file.doc"
Local $sSubst = "\g<0>/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)