// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[^:\n]+://)?[^/\n]+(?:(?:/[^/\n]+)*?/[^/.\n]+)?$").unwrap();
let string = "www.mysite.com
http://www.example.com
www.mysite.com/page
http://www.mysite.com/doc1/doc2/page
http://www.mysite.com/page/
http://www.mysite.com/dir1/dir2/file.php
http://www.mysite.com/file.jpg
www.mysite.com/file.html
www.mysite.com/file.doc";
let substitution = "\\g<0>/";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}