re = /^(?:[^:\n]+:\/\/)?[^\/\n]+(?:(?:\/[^\/\n]+)*?\/[^\/.\n]+)?$/m
str = 'www.mysite.com
http://www.example.com
www.mysite.com/page
http://www.mysite.com/doc1/doc2/page
http://www.mysite.com/page/
http://www.mysite.com/dir1/dir2/file.php
http://www.mysite.com/file.jpg
www.mysite.com/file.html
www.mysite.com/file.doc'
subst = '\\g<0>/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result