const regex = new RegExp('^(?:[^:\\n]+://)?[^/\\n]+(?:(?:/[^/\\n]+)*?/[^/.\\n]+)?$', 'gm')
const str = `www.mysite.com
http://www.example.com
www.mysite.com/page
http://www.mysite.com/doc1/doc2/page
http://www.mysite.com/page/
http://www.mysite.com/dir1/dir2/file.php
http://www.mysite.com/file.jpg
www.mysite.com/file.html
www.mysite.com/file.doc`;
const subst = `\g<0>/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);