import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^:\\n]+://)?[^/\\n]+(?:(?:/[^/\\n]+)*?/[^/.\\n]+)?$";
final String string = "www.mysite.com\n"
+ "http://www.example.com\n"
+ "www.mysite.com/page\n"
+ "http://www.mysite.com/doc1/doc2/page\n"
+ "http://www.mysite.com/page/\n"
+ "http://www.mysite.com/dir1/dir2/file.php\n"
+ "http://www.mysite.com/file.jpg\n"
+ "www.mysite.com/file.html\n"
+ "www.mysite.com/file.doc";
final String subst = "\\g<0>/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}