use strict;
my $str = 'www.mysite.com
http://www.example.com
www.mysite.com/page
http://www.mysite.com/doc1/doc2/page
http://www.mysite.com/page/
http://www.mysite.com/dir1/dir2/file.php
http://www.mysite.com/file.jpg
www.mysite.com/file.html
www.mysite.com/file.doc';
my $regex = qr/^(?:[^:\n]+://)?[^/\n]+(?:(?:/[^/\n]+)*?/[^/.\n]+)?$/mp;
my $subst = '\\g<0>/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";