#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(is)(\d+\.[a-zA-Z]{2,})"
Local $sString = "https://days.pravoslavie.ru/jpg/is847.jpg"
Local $sSubst = "ib$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)