use strict;
my $str = 'https://days.pravoslavie.ru/jpg/is847.jpg';
my $regex = qr/(is)(\d+\.[a-zA-Z]{2,})/p;
my $subst = 'ib$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";