$re = '/(is)(\d+\.[a-zA-Z]{2,})/';
$str = 'https://days.pravoslavie.ru/jpg/is847.jpg';
$subst = "ib$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;