const regex = /(is)(\d+\.[a-zA-Z]{2,})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(is)(\\d+\\.[a-zA-Z]{2,})', 'g')
const str = `https://days.pravoslavie.ru/jpg/is847.jpg`;
const subst = `ib$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);