using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(is)(\d+\.[a-zA-Z]{2,})";
string substitution = @"ib$2";
string input = @"https://days.pravoslavie.ru/jpg/is847.jpg";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}