re = /(is)(\d+\.[a-zA-Z]{2,})/
str = 'https://days.pravoslavie.ru/jpg/is847.jpg'
subst = 'ib$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result