// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(is)(\d+\.[a-zA-Z]{2,})").unwrap();
let string = "https://days.pravoslavie.ru/jpg/is847.jpg";
let substitution = "ib$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}