package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(is)(\d+\.[a-zA-Z]{2,})`)
var str = `https://days.pravoslavie.ru/jpg/is847.jpg`
var substitution = "ib$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}