import Foundation
let pattern = #"(is)(\d+\.[a-zA-Z]{2,})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://days.pravoslavie.ru/jpg/is847.jpg"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"ib$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)