# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?:end|something)\b//g;t' <<< "oh end oh something here"