import re
regex = re.compile(r"\b(?:end|something)\b")
test_str = "oh end oh something here"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)