$re = '/\b(?:end|something)\b/';
$str = 'oh end oh something here';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;