const regex = /\b(?:end|something)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:end|something)\\b', 'g')
const str = `oh end oh something here`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);