using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:end|something)\b";
string substitution = @"";
string input = @"oh end oh something here";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}