use strict;
my $str = 'oh end oh something here';
my $regex = qr/\b(?:end|something)\b/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";