import Foundation
let pattern = #"\b(?:end|something)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"oh end oh something here"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)