package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(?:end|something)\b`)
var str = `oh end oh something here`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}