re = /\b(?:end|something)\b/
str = 'oh end oh something here'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result