# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|\s)(#(\w+))/$1<a href="\/hash\/$3" class='hash_tag'>$2<\/a>/gm;t' <<< "To take this -> #test
#test <- to take this
to take this #test another word
to take this #Mest another word
To don't take this -> l'#09
to don't take this -> » or '"