#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^|\s)(#(\w+))"
Local $sString = "To take this -> #test" & @CRLF & _
"" & @CRLF & _
"#test <- to take this" & @CRLF & _
"" & @CRLF & _
"to take this #test another word" & @CRLF & _
"" & @CRLF & _
"to take this #Mest another word" & @CRLF & _
"" & @CRLF & _
"To don't take this -> l'#09" & @CRLF & _
"" & @CRLF & _
"to don't take this -> » or '"
Local $sSubst = "$1<a href="/hash/$3" class='hash_tag'>$2</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)