const regex = /(^|\s)(#(\w+))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\s)(#(\\w+))', 'gm')
const str = `To take this -> #test
#test <- to take this
to take this #test another word
to take this #Mest another word
To don't take this -> l'#09
to don't take this -> » or '`;
const subst = `$1<a href="/hash/$3" class='hash_tag'>$2</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);