use strict;
my $str = 'To take this -> #test
#test <- to take this
to take this #test another word
to take this #Mest another word
To don\'t take this -> l\'#09
to don\'t take this -> » or '';
my $regex = qr/(^|\s)(#(\w+))/mp;
my $subst = '$1<a href="/hash/$3" class=\'hash_tag\'>$2</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";