# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^|\s)(#(\w+))"
test_str = ("To take this -> #test\n\n"
"#test <- to take this\n\n"
"to take this #test another word\n\n"
"to take this #Mest another word\n\n"
"To don't take this -> l'#09\n\n"
"to don't take this -> » or '")
subst = "$1<a href=\"/hash/$3\" class='hash_tag'>$2</a>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.