// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^|\s)(#(\w+))").unwrap();
let string = "To take this -> #test
#test <- to take this
to take this #test another word
to take this #Mest another word
To don't take this -> l'#09
to don't take this -> » or '";
let substitution = "$1<a href=\"/hash/$3\" class='hash_tag'>$2</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}