package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|\s)(#(\w+))`)
var str = `To take this -> #test
#test <- to take this
to take this #test another word
to take this #Mest another word
To don't take this -> l'#09
to don't take this -> » or '`
var substitution = "$1<a href="/hash/$3" class='hash_tag'>$2</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}