re = /(^|\s)(#(\w+))/m
str = 'To take this -> #test
#test <- to take this
to take this #test another word
to take this #Mest another word
To don\'t take this -> l\'#09
to don\'t take this -> » or ''
subst = '$1<a href="/hash/$3" class=\'hash_tag\'>$2</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result