using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|\s)(#(\w+))";
string substitution = @"$1<a href=""/hash/$3"" class='hash_tag'>$2</a>";
string input = @"To take this -> #test
#test <- to take this
to take this #test another word
to take this #Mest another word
To don't take this -> l'#09
to don't take this -> » or '";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}