# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[dailyml place=“(.+)” year=“(\d\d\d\d)” month=“(\d\d)” day=“(\d\d)” time=“(\d\d):(\d\d)”\]/[dailyml place=“$1” year=“$2” month=“($3” day=“13” time=“12:34”]\n\n—TAGS—/gm;t' <<< "[dailyml place=“Here” year=“2023” month=“03” day=“13” time=“12:34”]"