package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[dailyml place=“(.+)” year=“(\d\d\d\d)” month=“(\d\d)” day=“(\d\d)” time=“(\d\d):(\d\d)”\]`)
var str = `[dailyml place=“Here” year=“2023” month=“03” day=“13” time=“12:34”]`
var substitution = "[dailyml place=“$1” year=“$2” month=“($3” day=“13” time=“12:34”]\n\n—TAGS—"
fmt.Println(re.ReplaceAllString(str, substitution))
}