import re
regex = re.compile(r"\[dailyml place=“(.+)” year=“(\d\d\d\d)” month=“(\d\d)” day=“(\d\d)” time=“(\d\d):(\d\d)”\]", flags=re.MULTILINE)
test_str = "[dailyml place=“Here” year=“2023” month=“03” day=“13” time=“12:34”]"
subst = "[dailyml place=“$1” year=“$2” month=“($3” day=“13” time=“12:34”]\\n\\n—TAGS—"
result = regex.sub(subst, test_str)
if result:
print(result)