using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[dailyml place=“(.+)” year=“(\d\d\d\d)” month=“(\d\d)” day=“(\d\d)” time=“(\d\d):(\d\d)”\]";
string substitution = @"[dailyml place=“$1” year=“$2” month=“($3” day=“13” time=“12:34”]\n\n—TAGS—";
string input = @"[dailyml place=“Here” year=“2023” month=“03” day=“13” time=“12:34”]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}