#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[dailyml place=“(.+)” year=“(\d\d\d\d)” month=“(\d\d)” day=“(\d\d)” time=“(\d\d):(\d\d)”\]"
Local $sString = "[dailyml place=“Here” year=“2023” month=“03” day=“13” time=“12:34”]"
Local $sSubst = "[dailyml place=“$1” year=“$2” month=“($3” day=“13” time=“12:34”]\n\n—TAGS—"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)