import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[dailyml place=“(.+)” year=“(\\d\\d\\d\\d)” month=“(\\d\\d)” day=“(\\d\\d)” time=“(\\d\\d):(\\d\\d)”\\]";
final String string = "[dailyml place=“Here” year=“2023” month=“03” day=“13” time=“12:34”]";
final String subst = "[dailyml place=“$1” year=“$2” month=“($3” day=“13” time=“12:34”]\\n\\n—TAGS—";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}