// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[dailyml place=“(.+)” year=“(\d\d\d\d)” month=“(\d\d)” day=“(\d\d)” time=“(\d\d):(\d\d)”\]").unwrap();
let string = "[dailyml place=“Here” year=“2023” month=“03” day=“13” time=“12:34”]";
let substitution = "[dailyml place=“$1” year=“$2” month=“($3” day=“13” time=“12:34”]\\n\\n—TAGS—";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}