#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.{1,22})(?:,|$)"
Local $sString = "test1,test2,test3,test4,test5" & @CRLF & _
"test1,test2,test3,test4,test5,test1,test2,test3,test4,test5,test6" & @CRLF & _
""
Local $sSubst = "$1\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)